Sandip's Programming Zen

An attempt to share tech/coding experiences

Posts Tagged ‘ASP.Net crash

Solution: Event ID ( 0 ) Error – Application Crashing

with one comment

Recently I have got a weird error on our production web server. The server is Win 2003 R2 running with Framework 1.1 application.

The following error is logged in event viewer and whenever it occurred our server crashed and mostly we have to reboot to make the application working.

The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: .NET Runtime version 1.1.4322.2300- Setup Error: Failed to load resources from resource file.

As it seems it does not provide any clue what is going wrong. After researching Net for hours I have seen number of people reporting this error in different context. So there is no fixed reason or solution.

However, I have tried to do everything what some people have suggested as solutions and one had done the trick for me. I am putting them together some of the possible solutions (as I believed) those may fix the problem if you ever encounter.

  1. Stake overflow is the number one cause according to most and it usually happens because of recursive function in code. You have to go through your code and find out and fix.
  2. As it gives a hint in message itself “Failed to load resources from resource file“. Means you may be using a resource file in your application and now it can’t be loaded or accessed.
  3. Check in your code if there are any threads which stuck in any of your function and goes into infinite loop. This can be easily found out as this may be happening on carrying out particular action on your application.
  4. If you have used any “third party” library where you don’t know how it works inside then better check. Try to remove them from your project and see if the error goes away.

If you find more solutions then please update me as that may save someone’s hours of time.

Written by Sandip

January 25, 2008 at 5:10 pm